Login with FQDN name

Moderator: gregober

Post Reply
hboxhorn
Posts: 4
Joined: 20 Sep 2019, 22:04

Login with FQDN name

Post by hboxhorn » 20 Sep 2019, 22:07

I have no problem logging into the dynfi server if I use in my browser a IP address. If I use then instead of the IP address the FQDN name I get the error message that I have an "error fteching token!".

What could be the reason for it ?

Thanks
Petrus
Posts: 4
Joined: 24 Sep 2019, 12:21

Re: Login with FQDN name

Post by Petrus » 24 Sep 2019, 12:24

Hello hboxhorn

Are you running DynFi behind HTTP proxy (like Nginx, Apache HTTP serveur) or you're trying to access DynFi by FQDN directly ?
User avatar
gregober
Posts: 109
Joined: 26 Mar 2019, 15:06

Re: Login with FQDN name

Post by gregober » 24 Sep 2019, 16:39

You should normaly be able to access your dynfi install using either :
http://your.ip.address:9090
or
http://your.fqdn.domain:9090

If you could provide us with more contextual info, we would be able to help you.
hboxhorn
Posts: 4
Joined: 20 Sep 2019, 22:04

Re: Login with FQDN name

Post by hboxhorn » 24 Sep 2019, 20:01

I connect directly to the Server without any proxy in between.
Petrus
Posts: 4
Joined: 24 Sep 2019, 12:21

Re: Login with FQDN name

Post by Petrus » 25 Sep 2019, 14:27

Hi hboxhorn

In case you haven't touched ipAndPort, this should work.
However, if you have set ipAndPort in the configuration (e.g. to bind only to the public IP address), then you should also configure corsAllowOrigin (https://dynfi.com/dynfi-docs/configurat ... lloworigin), e.g. set it to *, so that:
corsAllowOrigin=*
You should be able to limit that to your FQDN.
Let me know if that helped, please.
hboxhorn
Posts: 4
Joined: 20 Sep 2019, 22:04

Re: Login with FQDN name

Post by hboxhorn » 27 Sep 2019, 18:51

Hello Petrus,

setting the corsAllowOrigin=* was the solution :)

Thank you so much !
Herb
Post Reply