Problème de connexion sortante

This forum is the place to discuss any installation problem or question you might have related to DynFi Firewall.

Moderator: gregober

Post Reply
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Problème de connexion sortante

Post by ThierryB » 11 Dec 2023, 16:43

Bonjour,
Je viens d'installer DynFi Firewall version 3.01.001 sur une vm Proxmox v8.
L'installation s'est bien passée et j'ai bien renseigné les reseaux LAN, WAN et la passerrelle.
Je connecte une autre vm sous Windows 10 en passant par dynfi. Tout va bien, j'ai bien accès à internet.
Malheureusement, le trafic sortant semble limité par le firewall (je n'ai pas touché encore aux règles) car quand je fais un test de débit internet, j'ai bien un bon débit entrant mais le débit sortant est bloqué au bout de 2 ou 3 secondes.
Pareil si je j'envoi un fichier par FTP, le fichier bloque à environ 500~700 Ko. En réception, pas de souci. En navigation web, ça va aussi.
D'ou cela peut venir SVP?
Autre question: ou se trouve le journal en temps réel du firewall pour voir ce que fait le FW ?
Merci
User avatar
gregober
Posts: 228
Joined: 26 Mar 2019, 15:06

Re: Problème de connexion sortante

Post by gregober » 11 Dec 2023, 16:56

Les logs se trouvent dans : Firewall >> Rules >> Interface_xx
En haut à droite vous avez un bouton "Log" dans lequel vous pouvez accéder aux logs par défaut du pare-feu.

Il faut regarder ce qui bloque à ce niveau.

Je regarderais en priorité les parties suivantes :
- Règles de pare-feu
- NAT en sortie
- MTU
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Re: Problème de connexion sortante

Post by ThierryB » 11 Dec 2023, 17:41

Merci pour votre réponse rapide.
j'ai regardé les différents points cités, et rien de particulier.
Effectivement les logs ne sont pas au meme endroit que dans Opnsense ;)
Comme je n'ai pas touché aux règles encore, je n'avais pas vu.

J'ai refais un test en regardant les logs et rien de particulier:
-Le firewall ne donne aucun blocage
-le NAT sortant est de base : les 2 règles auto
-Le MTU est standard donc 1500

Et curieusement, ca ne bloque plus ! je ne comprends pas pourquoi, je n'ai rien touché.
Le principal c'est que ca fonctionne.
Merci
User avatar
gregober
Posts: 228
Joined: 26 Mar 2019, 15:06

Re: Problème de connexion sortante

Post by gregober » 11 Dec 2023, 17:52

Ok, good news !

Il met un peu de temps à charger ses services au démarrage, il faut être patient.
Ensuite tout est en place et cela fonctionne bien.

Si vous trouvez des bugs n'hésitez pas à les faire remonter.
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Re: Problème de connexion sortante

Post by ThierryB » 11 Dec 2023, 18:03

Je viens de le redémarrer sans rien modifier et rebelotte, ca bloque de nouveau. je vais le laisser comme ça et je verrai demain ce qu'il en est.
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Re: Problème de connexion sortante

Post by ThierryB » 12 Dec 2023, 09:00

Nouvel essai: ça bloque toujours.
J'ai désactivé le NAT sortant : rien ne change
Les règles du FW sont celles de base qui sont mises à l'installation du FW
>>> D'ailleurs j'ai remarqué un petit bug: il manque un T à entranT à différents endroits
J'ai testé en changeant d'autres paramètres du FW mais rien y fait.
Je ne peux pas testé les floating rules auto générées car je ne peux pas les désactiver afin de déterminer si l'une bugue.

Le seul moyen qui fonctionne est la désactivation du FW: pour les tests ça va mais pas en prod !

En faisant l'installation avec OpnSense, le problème est identique. Avec une subtilité, je dois mettre l'optimisation du FW sur conservateur sinon le FW bloque avec des messages dans les logs : Default deny / state violation rule

Ce que je ne comprends pas, c'est que je teste sur une installation toute fraiche sans personnalisation. Donc théoriquement, tout le monde devrait être confronté à ce même problème logiquement ?!
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Re: Problème de connexion sortante

Post by ThierryB » 13 Dec 2023, 10:51

après plusieurs tentatives, rien ne fonctionne. La seule qui marche est la désactivation du FW. Je suis coincé.
Je vais abandonner la solution DynFi/OpnSense pour revenir sur IPFire.
Je suis persuadé qu'il n'y a probablement pas grand chose à faire mais je ne trouve pas et pas suffisamment calé en sécurité réseau.
Peut etre un jour j'y reviendrai.
Bonne continuation à tous
User avatar
gregober
Posts: 228
Joined: 26 Mar 2019, 15:06

Re: Problème de connexion sortante

Post by gregober » 13 Dec 2023, 10:52

Vous devriez essayer d'inverser les interfaces.
J'ai l'impression que vous avez branché le WAN à la place du LAN et vice-versa d'après ce que vous décrivez.
ThierryB
Posts: 6
Joined: 11 Dec 2023, 16:30

Re: Problème de connexion sortante

Post by ThierryB » 13 Dec 2023, 15:16

non les interfaces sont bonnes.
J'ai installé IPFire avec la même configuration et ça fonctionne de suite avec la config par défaut.
Post Reply